The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / keyutils / 0004-Makefile-for-buildroot.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/keyutils/0004-Makefile-for-buildroot.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/keyutils/0004-Makefile-for-buildroot.patch
new file mode 100644 (file)
index 0000000..1e19f77
--- /dev/null
@@ -0,0 +1,19 @@
+Makefile: Don't call "ln" directly
+
+Signed-off-by: Vicente Olivert Riera <vincent.riera@imgtec.com>
+
+--- keyutils-1.5.9/Makefile.orig       2014-09-22 16:05:14.117007430 +0100
++++ keyutils-1.5.9/Makefile    2014-09-22 16:06:26.053219336 +0100
+@@ -123,10 +123,10 @@ endif
+ ifeq ($(NO_SOLIB),0)
+ all: $(DEVELLIB)
+ $(DEVELLIB): $(SONAME)
+-      ln -sf $< $@
++      $(LNS) $< $@
+ $(SONAME): $(LIBNAME)
+-      ln -sf $< $@
++      $(LNS) $< $@
+ LIBVERS := -shared -Wl,-soname,$(SONAME) -Wl,--version-script,version.lds