The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / keyutils / 0002-fix-install-rule.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/keyutils/0002-fix-install-rule.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/keyutils/0002-fix-install-rule.patch
new file mode 100644 (file)
index 0000000..3670d28
--- /dev/null
@@ -0,0 +1,20 @@
+Makefile: fix install rule
+
+Do not link the .so with an absolute path, otherwise it may point to
+the host library.
+
+Based on the former patch by Yann E. MORIN.
+
+Signed-off-by: Vicente Olivert Riera <vincent.riera@imgtec.com>
+
+--- keyutils-1.5.9/Makefile.orig       2014-09-22 16:13:41.593562765 +0100
++++ keyutils-1.5.9/Makefile    2014-09-22 16:14:05.377963952 +0100
+@@ -168,7 +168,7 @@ ifeq ($(NO_SOLIB),0)
+       $(INSTALL) -D $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(LIBNAME)
+       $(LNS) $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(SONAME)
+       mkdir -p $(DESTDIR)$(USRLIBDIR)
+-      $(LNS) $(LIBDIR)/$(SONAME) $(DESTDIR)$(USRLIBDIR)/$(DEVELLIB)
++      $(LNS) $(SONAME) $(DESTDIR)$(USRLIBDIR)/$(DEVELLIB)
+ endif
+       $(INSTALL) -D keyctl $(DESTDIR)$(BINDIR)/keyctl
+       $(INSTALL) -D request-key $(DESTDIR)$(SBINDIR)/request-key