The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / kexec / kexec.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/kexec/kexec.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/kexec/kexec.mk
new file mode 100644 (file)
index 0000000..d158406
--- /dev/null
@@ -0,0 +1,26 @@
+################################################################################
+#
+# kexec
+#
+################################################################################
+
+KEXEC_VERSION = 2.0.9
+KEXEC_SOURCE = kexec-tools-$(KEXEC_VERSION).tar.xz
+KEXEC_SITE = $(BR2_KERNEL_MIRROR)/linux/utils/kernel/kexec
+KEXEC_LICENSE = GPLv2
+KEXEC_LICENSE_FILES = COPYING
+
+ifeq ($(BR2_PACKAGE_KEXEC_ZLIB),y)
+KEXEC_CONF_OPTS += --with-zlib
+KEXEC_DEPENDENCIES = zlib
+else
+KEXEC_CONF_OPTS += --without-zlib
+endif
+
+define KEXEC_REMOVE_LIB_TOOLS
+       rm -rf $(TARGET_DIR)/usr/lib/kexec-tools
+endef
+
+KEXEC_POST_INSTALL_TARGET_HOOKS += KEXEC_REMOVE_LIB_TOOLS
+
+$(eval $(autotools-package))