The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / kexec-lite / kexec-lite.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/kexec-lite/kexec-lite.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/kexec-lite/kexec-lite.mk
new file mode 100644 (file)
index 0000000..7e3c8d3
--- /dev/null
@@ -0,0 +1,20 @@
+################################################################################
+#
+# kexec-lite
+#
+################################################################################
+
+KEXEC_LITE_VERSION = fb8543fea3beb0522b5a63a74ea1a845dbd7b954
+KEXEC_LITE_SITE = $(call github,antonblanchard,kexec-lite,$(KEXEC_LITE_VERSION))
+KEXEC_LITE_LICENSE = GPLv2+
+KEXEC_LITE_DEPENDENCIES = elfutils dtc
+
+define KEXEC_LITE_BUILD_CMDS
+       $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) all
+endef
+
+define KEXEC_LITE_INSTALL_TARGET_CMDS
+       $(INSTALL) -D -m 755 $(@D)/kexec $(TARGET_DIR)/usr/sbin/kexec
+endef
+
+$(eval $(generic-package))