The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / jsmin / jsmin.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/jsmin/jsmin.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/jsmin/jsmin.mk
new file mode 100644 (file)
index 0000000..a66ba71
--- /dev/null
@@ -0,0 +1,29 @@
+################################################################################
+#
+# jsmin
+#
+################################################################################
+
+JSMIN_VERSION = 1bf6ce5f74a9f8752ac7f5d115b8d7ccb31cfe1b
+JSMIN_SITE = $(call github,douglascrockford,JSMin,$(JSMIN_VERSION))
+JSMIN_LICENSE = MIT
+JSMIN_LICENSE_FILES = jsmin.c
+
+define JSMIN_BUILD_CMDS
+       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) jsmin
+endef
+
+define JSMIN_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 0755 -D $(@D)/jsmin $(TARGET_DIR)/usr/bin/jsmin
+endef
+
+define HOST_JSMIN_BUILD_CMDS
+       $(HOST_CONFIGURE_OPTS) $(MAKE) -C $(@D) jsmin
+endef
+
+define HOST_JSMIN_INSTALL_CMDS
+       $(INSTALL) -m 0755 -D $(@D)/jsmin $(HOST_DIR)/usr/bin/jsmin
+endef
+
+$(eval $(generic-package))
+$(eval $(host-generic-package))