The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / jquery-sparkline / jquery-sparkline.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/jquery-sparkline/jquery-sparkline.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/jquery-sparkline/jquery-sparkline.mk
new file mode 100644 (file)
index 0000000..4a7b94e
--- /dev/null
@@ -0,0 +1,21 @@
+################################################################################
+#
+# jquery-sparkline
+#
+################################################################################
+
+JQUERY_SPARKLINE_VERSION = 2.1.2
+JQUERY_SPARKLINE_SITE = http://www.omnipotent.net/jquery.sparkline/$(JQUERY_SPARKLINE_VERSION)
+JQUERY_SPARKLINE_SOURCE = jquery.sparkline.min.js
+JQUERY_SPARKLINE_LICENSE = BSD-3c
+
+define JQUERY_SPARKLINE_EXTRACT_CMDS
+       cp $(DL_DIR)/$(JQUERY_SPARKLINE_SOURCE) $(@D)
+endef
+
+define JQUERY_SPARKLINE_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 0644 -D $(@D)/$(JQUERY_SPARKLINE_SOURCE) \
+               $(TARGET_DIR)/var/www/jquery.sparkline.js
+endef
+
+$(eval $(generic-package))