The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / joe / joe.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/joe/joe.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/joe/joe.mk
new file mode 100644 (file)
index 0000000..e86007e
--- /dev/null
@@ -0,0 +1,25 @@
+################################################################################
+#
+# joe
+#
+################################################################################
+
+JOE_VERSION = 3.7
+JOE_SITE = http://downloads.sourceforge.net/project/joe-editor/JOE%20sources/joe-$(JOE_VERSION)
+JOE_LICENSE = GPLv1+
+JOE_LICENSE_FILES = COPYING
+
+ifeq ($(BR2_PACKAGE_NCURSES),y)
+JOE_DEPENDENCIES += ncurses
+JOE_CONF_OPTS += --enable-curses
+else
+JOE_CONF_OPTS += --disable-curses
+endif
+
+ifneq ($(BR2_PACKAGE_JOE_FULL),y)
+define JOE_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 0755 -D $(@D)/joe $(TARGET_DIR)/usr/bin/joe
+endef
+endif
+
+$(eval $(autotools-package))