The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / jamvm / jamvm.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/jamvm/jamvm.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/jamvm/jamvm.mk
new file mode 100644 (file)
index 0000000..b1520ad
--- /dev/null
@@ -0,0 +1,25 @@
+################################################################################
+#
+# jamvm
+#
+################################################################################
+
+JAMVM_VERSION = 2.0.0
+JAMVM_SITE = http://downloads.sourceforge.net/project/jamvm/jamvm/JamVM%20$(JAMVM_VERSION)
+JAMVM_LICENSE = GPLv2+
+JAMVM_LICENSE_FILES = COPYING
+JAMVM_DEPENDENCIES = zlib classpath
+# int inlining seems to crash jamvm, don't build shared version of internal lib
+JAMVM_CONF_OPTS = \
+       --with-classpath-install-dir=/usr \
+       --disable-int-inlining \
+       --disable-shared \
+       --without-pic
+
+# jamvm has ARM assembly code that cannot be compiled in Thumb2 mode,
+# so we must force traditional ARM mode.
+ifeq ($(BR2_arm),y)
+JAMVM_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -marm"
+endif
+
+$(eval $(autotools-package))