The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / iw / iw.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/iw/iw.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/iw/iw.mk
new file mode 100644 (file)
index 0000000..4fd18ac
--- /dev/null
@@ -0,0 +1,25 @@
+################################################################################
+#
+# iw
+#
+################################################################################
+
+IW_VERSION = 4.0
+IW_SOURCE = iw-$(IW_VERSION).tar.xz
+IW_SITE = $(BR2_KERNEL_MIRROR)/software/network/iw
+IW_LICENSE = iw license
+IW_LICENSE_FILES = COPYING
+IW_DEPENDENCIES = host-pkgconf libnl
+IW_MAKE_OPTS = CC="$(TARGET_CC)" LD="$(TARGET_LD)" LDFLAGS="$(TARGET_LDFLAGS)"
+IW_MAKE_ENV = PKG_CONFIG="$(HOST_DIR)/usr/bin/pkg-config" \
+       GIT_DIR=$(IW_DIR)
+
+define IW_BUILD_CMDS
+       $(IW_MAKE_ENV) $(MAKE) $(IW_MAKE_OPTS) -C $(@D)
+endef
+
+define IW_INSTALL_TARGET_CMDS
+       $(IW_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) install
+endef
+
+$(eval $(generic-package))