The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / iproute2 / iproute2.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/iproute2/iproute2.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/iproute2/iproute2.mk
new file mode 100644 (file)
index 0000000..a8f4400
--- /dev/null
@@ -0,0 +1,74 @@
+################################################################################
+#
+# iproute2
+#
+################################################################################
+
+IPROUTE2_VERSION = 4.0.0
+IPROUTE2_SOURCE = iproute2-$(IPROUTE2_VERSION).tar.xz
+IPROUTE2_SITE = $(BR2_KERNEL_MIRROR)/linux/utils/net/iproute2
+IPROUTE2_DEPENDENCIES = host-bison host-flex host-pkgconf
+IPROUTE2_LICENSE = GPLv2
+IPROUTE2_LICENSE_FILES = COPYING
+
+# If both iproute2 and busybox are selected, make certain we win
+# the fight over who gets to have their utils actually installed.
+ifeq ($(BR2_PACKAGE_BUSYBOX),y)
+IPROUTE2_DEPENDENCIES += busybox
+endif
+
+# If we've got iptables enable xtables support for tc
+ifeq ($(BR2_PACKAGE_IPTABLES)x$(BR2_STATIC_LIBS),yx)
+IPROUTE2_DEPENDENCIES += iptables
+define IPROUTE2_WITH_IPTABLES
+       # Makefile is busted so it never passes IPT_LIB_DIR properly
+       $(SED) "s/-DIPT/-DXT/" $(IPROUTE2_DIR)/tc/Makefile
+endef
+else
+define IPROUTE2_WITH_IPTABLES
+       # em_ipset needs xtables, but configure misdetects it
+       echo "TC_CONFIG_IPSET:=n" >>$(IPROUTE2_DIR)/Config
+       echo "TC_CONFIG_XT:=n" >>$(IPROUTE2_DIR)/Config
+endef
+endif
+
+# arpd needs BerkeleyDB and links against pthread
+ifeq ($(BR2_PACKAGE_BERKELEYDB_COMPAT185)$(BR2_TOOLCHAIN_HAS_THREADS),yy)
+IPROUTE2_DEPENDENCIES += berkeleydb
+else
+define IPROUTE2_DISABLE_ARPD
+       $(SED) "/^TARGETS=/s: arpd : :" $(IPROUTE2_DIR)/misc/Makefile
+endef
+endif
+
+# ifcfg needs bash
+ifeq ($(BR2_PACKAGE_BASH),)
+define IPROUTE2_REMOVE_IFCFG
+       rm -f $(TARGET_DIR)/sbin/ifcfg
+endef
+endif
+
+define IPROUTE2_CONFIGURE_CMDS
+       $(SED) 's/gcc/$$CC $$CFLAGS/g' $(@D)/configure
+       cd $(@D) && $(TARGET_CONFIGURE_OPTS) ./configure
+       $(IPROUTE2_DISABLE_ARPD)
+       $(IPROUTE2_WITH_IPTABLES)
+endef
+
+define IPROUTE2_BUILD_CMDS
+       $(SED) 's/$$(CCOPTS)//' $(@D)/netem/Makefile
+       $(TARGET_MAKE_ENV) LDFLAGS="$(TARGET_LDFLAGS)" $(MAKE) \
+               DBM_INCLUDE="$(STAGING_DIR)/usr/include" \
+               CCOPTS="$(TARGET_CFLAGS) -D_GNU_SOURCE" \
+               SHARED_LIBS="$(if $(BR2_STATIC_LIBS),n,y)" -C $(@D)
+endef
+
+define IPROUTE2_INSTALL_TARGET_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR="$(TARGET_DIR)" \
+               SBINDIR=/sbin \
+               DOCDIR=/usr/share/doc/iproute2-$(IPROUTE2_VERSION) \
+               MANDIR=/usr/share/man install
+       $(IPROUTE2_REMOVE_IFCFG)
+endef
+
+$(eval $(generic-package))