The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / ipmiutil / ipmiutil.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/ipmiutil/ipmiutil.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/ipmiutil/ipmiutil.mk
new file mode 100644 (file)
index 0000000..6f462b9
--- /dev/null
@@ -0,0 +1,27 @@
+################################################################################
+#
+# ipmiutil
+#
+################################################################################
+
+IPMIUTIL_VERSION = 2.9.5
+IPMIUTIL_SITE = http://sourceforge.net/projects/ipmiutil/files/
+IPMIUTIL_LICENSE = BSD-3c
+IPMIUTIL_LICENSE_FILES = COPYING
+# We're patching configure.ac , lib/Makefile.am and lib/lanplus/Makefile.am
+IPMIUTIL_AUTORECONF = YES
+
+IPMIUTIL_MAKE = $(MAKE1)
+
+# forgets to link against libcrypto dependencies breaking static link
+ifeq ($(BR2_PACKAGE_OPENSSL)x$(BR2_STATIC_LIBS),yx)
+# tests against distro libcrypto so it might get a false positive when
+# the openssl version is old, so force it off
+# SKIP_MD2 can be used only if ALLOW_GNU is defined.
+IPMIUTIL_CONF_OPTS += CPPFLAGS="$(TARGET_CPPFLAGS) -DALLOW_GNU -DSKIP_MD2"
+IPMIUTIL_DEPENDENCIES += openssl
+else
+IPMIUTIL_CONF_OPTS += --disable-lanplus
+endif
+
+$(eval $(autotools-package))