The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / ipmitool / ipmitool.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/ipmitool/ipmitool.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/ipmitool/ipmitool.mk
new file mode 100644 (file)
index 0000000..137987f
--- /dev/null
@@ -0,0 +1,30 @@
+################################################################################
+#
+# ipmitool
+#
+################################################################################
+
+IPMITOOL_VERSION = 1.8.14
+IPMITOOL_SOURCE = ipmitool-$(IPMITOOL_VERSION).tar.bz2
+IPMITOOL_SITE = http://downloads.sourceforge.net/project/ipmitool/ipmitool/$(IPMITOOL_VERSION)
+IPMITOOL_LICENSE = BSD-3c
+IPMITOOL_LICENSE_FILES = COPYING
+
+ifeq ($(BR2_PACKAGE_IPMITOOL_LANPLUS),y)
+IPMITOOL_DEPENDENCIES += openssl
+else
+IPMITOOL_CONF_OPTS += --disable-intf-lanplus
+endif
+
+ifeq ($(BR2_PACKAGE_READLINE),y)
+IPMITOOL_DEPENDENCIES += readline
+endif
+
+ifeq ($(BR2_PACKAGE_IPMITOOL_IPMIEVD),)
+define IPMITOOL_REMOVE_IPMIEVD
+       $(RM) -f $(TARGET_DIR)/usr/sbin/ipmievd
+endef
+IPMITOOL_POST_INSTALL_TARGET_HOOKS += IPMITOOL_REMOVE_IPMIEVD
+endif
+
+$(eval $(autotools-package))