The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / iozone / iozone.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/iozone/iozone.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/iozone/iozone.mk
new file mode 100644 (file)
index 0000000..0662207
--- /dev/null
@@ -0,0 +1,33 @@
+################################################################################
+#
+# iozone
+#
+################################################################################
+
+IOZONE_VERSION = 3_430
+IOZONE_SOURCE = iozone$(IOZONE_VERSION).tar
+IOZONE_SITE = http://www.iozone.org/src/current
+IOZONE_LICENSE = IOzone license (NO DERIVED WORKS ALLOWED)
+# IOzone license details can be found at:
+# http://www.iozone.org/docs/Iozone_License.txt
+
+# No threading target is non-AIO as well
+ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),)
+IOZONE_TARGET = linux-noth
+# AIO support not available on uClibc, use the linux (non-aio) target.
+else ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
+IOZONE_TARGET = linux-noaio
+else
+IOZONE_TARGET = linux
+endif
+
+define IOZONE_BUILD_CMDS
+       $(MAKE) $(TARGET_CONFIGURE_OPTS) $(IOZONE_TARGET) -C $(@D)/src/current
+endef
+
+define IOZONE_INSTALL_TARGET_CMDS
+       $(INSTALL) -D -m 755 $(@D)/src/current/iozone \
+               $(TARGET_DIR)/usr/bin/iozone
+endef
+
+$(eval $(generic-package))