The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / input-event-daemon / input-event-daemon.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/input-event-daemon/input-event-daemon.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/input-event-daemon/input-event-daemon.mk
new file mode 100644 (file)
index 0000000..67b8cc4
--- /dev/null
@@ -0,0 +1,30 @@
+################################################################################
+#
+# input-event-daemon
+#
+################################################################################
+
+INPUT_EVENT_DAEMON_VERSION = v0.1.3
+INPUT_EVENT_DAEMON_SITE = $(call github,gandro,input-event-daemon,$(INPUT_EVENT_DAEMON_VERSION))
+INPUT_EVENT_DAEMON_LICENSE = input-event-daemon license
+INPUT_EVENT_DAEMON_LICENSE_FILES = README
+
+define INPUT_EVENT_DAEMON_BUILD_CMDS
+       touch  $(@D)/input-event-table.h
+       $(MAKE) CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" \
+               LDFLAGS="$(TARGET_LDFLAGS)" -C $(@D)
+endef
+
+define INPUT_EVENT_DAEMON_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 755 -D $(@D)/input-event-daemon \
+               $(TARGET_DIR)/usr/bin/input-event-daemon
+       $(INSTALL) -m 644 -D $(@D)/docs/sample.conf \
+               $(TARGET_DIR)/etc/input-event-daemon.conf
+endef
+
+define INPUT_EVENT_DAEMON_INSTALL_INIT_SYSV
+       $(INSTALL) -m 0755 -D package/input-event-daemon/S99input-event-daemon \
+               $(TARGET_DIR)/etc/init.d/S99input-event-daemon
+endef
+
+$(eval $(generic-package))