The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / icu / icu.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/icu/icu.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/icu/icu.mk
new file mode 100644 (file)
index 0000000..2590178
--- /dev/null
@@ -0,0 +1,41 @@
+################################################################################
+#
+# icu
+#
+################################################################################
+
+ICU_VERSION = 55.1
+ICU_SOURCE = icu4c-$(subst .,_,$(ICU_VERSION))-src.tgz
+ICU_SITE = http://download.icu-project.org/files/icu4c/$(ICU_VERSION)
+ICU_LICENSE = ICU License
+ICU_LICENSE_FILES = license.html
+
+ICU_DEPENDENCIES = host-icu
+ICU_INSTALL_STAGING = YES
+ICU_CONFIG_SCRIPTS = icu-config
+ICU_CONF_OPTS = \
+       --with-cross-build=$(HOST_ICU_DIR)/source \
+       --disable-samples \
+       --disable-tests
+HOST_ICU_CONF_OPTS = \
+       --disable-samples \
+       --disable-tests \
+       --disable-extras \
+       --disable-icuio \
+       --disable-layout \
+       --disable-renaming
+ICU_MAKE = $(MAKE1)
+ICU_SUBDIR = source
+HOST_ICU_SUBDIR = source
+
+ICU_CUSTOM_DATA_PATH = $(call qstrip,$(BR2_PACKAGE_ICU_CUSTOM_DATA_PATH))
+
+ifneq ($(ICU_CUSTOM_DATA_PATH),)
+define ICU_COPY_CUSTOM_DATA
+       cp $(ICU_CUSTOM_DATA_PATH) $(@D)/source/data/in/
+endef
+ICU_POST_PATCH_HOOKS += ICU_COPY_CUSTOM_DATA
+endif
+
+$(eval $(autotools-package))
+$(eval $(host-autotools-package))