The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / hwdata / hwdata.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/hwdata/hwdata.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/hwdata/hwdata.mk
new file mode 100644 (file)
index 0000000..f8cffcd
--- /dev/null
@@ -0,0 +1,19 @@
+################################################################################
+#
+# hwdata
+#
+################################################################################
+
+HWDATA_VERSION = 0.267
+HWDATA_SOURCE = hwdata_$(HWDATA_VERSION).orig.tar.gz
+HWDATA_PATCH = hwdata_$(HWDATA_VERSION)-1.diff.gz
+HWDATA_SITE = http://snapshot.debian.org/archive/debian/20141023T043132Z/pool/main/h/hwdata
+HWDATA_LICENSE = GPLv2+ or XFree86 1.0 license
+HWDATA_LICENSE_FILES = COPYING LICENSE
+
+define HWDATA_INSTALL_TARGET_CMDS
+       $(INSTALL) -D -m 644 $(@D)/pci.ids $(TARGET_DIR)/usr/share/hwdata/pci.ids
+       $(INSTALL) -D -m 644 $(@D)/usb.ids $(TARGET_DIR)/usr/share/hwdata/usb.ids
+endef
+
+$(eval $(generic-package))