The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / haveged / haveged.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/haveged/haveged.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/haveged/haveged.mk
new file mode 100644 (file)
index 0000000..c68f766
--- /dev/null
@@ -0,0 +1,25 @@
+################################################################################
+#
+# haveged
+#
+################################################################################
+
+HAVEGED_VERSION = 1.9.1
+HAVEGED_SITE = http://www.issihosts.com/haveged
+HAVEGED_LICENSE = GPLv3+
+HAVEGED_LICENSE_FILES = COPYING
+
+define HAVEGED_INSTALL_INIT_SYSV
+       $(INSTALL) -m 755 -D package/haveged/S21haveged \
+               $(TARGET_DIR)/etc/init.d/S21haveged
+endef
+
+define HAVEGED_INSTALL_INIT_SYSTEMD
+       $(INSTALL) -D -m 644 package/haveged/haveged.service \
+               $(TARGET_DIR)/usr/lib/systemd/system/haveged.service
+       mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
+       ln -fs /usr/lib/systemd/system/haveged.service \
+               $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/haveged.service
+endef
+
+$(eval $(autotools-package))