The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / haserl / haserl.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/haserl/haserl.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/haserl/haserl.mk
new file mode 100644 (file)
index 0000000..93d64c8
--- /dev/null
@@ -0,0 +1,32 @@
+################################################################################
+#
+# haserl
+#
+################################################################################
+
+HASERL_VERSION = 0.9.35
+HASERL_SITE = http://downloads.sourceforge.net/project/haserl/haserl-devel
+HASERL_LICENSE = GPLv2
+HASERL_LICENSE_FILES = COPYING
+HASERL_DEPENDENCIES = host-pkgconf
+
+ifeq ($(BR2_PACKAGE_HASERL_WITH_LUA),y)
+HASERL_CONF_OPTS += --with-lua
+HASERL_DEPENDENCIES += lua
+
+# liblua uses dlopen when dynamically linked
+ifneq ($(BR2_STATIC_LIBS),y)
+HASERL_CONF_ENV += LIBS="-ldl"
+endif
+
+else
+HASERL_CONF_OPTS += --without-lua
+endif
+
+define HASERL_REMOVE_EXAMPLES
+       rm -rf $(TARGET_DIR)/usr/share/haserl
+endef
+
+HASERL_POST_INSTALL_TARGET_HOOKS += HASERL_REMOVE_EXAMPLES
+
+$(eval $(autotools-package))