The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / hans / hans.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/hans/hans.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/hans/hans.mk
new file mode 100644 (file)
index 0000000..bda091f
--- /dev/null
@@ -0,0 +1,20 @@
+################################################################################
+#
+# hans
+#
+################################################################################
+
+HANS_VERSION = 0.4.4
+HANS_SITE = http://downloads.sourceforge.net/project/hanstunnel/source
+HANS_LICENSE = GPLv3+
+HANS_LICENSE_FILES = LICENSE
+
+define HANS_BUILD_CMDS
+       $(MAKE) GCC="$(TARGET_CC)" GPP="$(TARGET_CXX)" -C $(@D)
+endef
+
+define HANS_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 755 -D $(@D)/hans $(TARGET_DIR)/usr/sbin/hans
+endef
+
+$(eval $(generic-package))