The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / gstreamer1 / gstreamer1 / gstreamer1.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/gstreamer1/gstreamer1/gstreamer1.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/gstreamer1/gstreamer1/gstreamer1.mk
new file mode 100644 (file)
index 0000000..7840284
--- /dev/null
@@ -0,0 +1,39 @@
+################################################################################
+#
+# gstreamer1
+#
+################################################################################
+
+GSTREAMER1_VERSION = 1.4.5
+GSTREAMER1_SOURCE = gstreamer-$(GSTREAMER1_VERSION).tar.xz
+GSTREAMER1_SITE = http://gstreamer.freedesktop.org/src/gstreamer
+GSTREAMER1_INSTALL_STAGING = YES
+GSTREAMER1_LICENSE_FILES = COPYING
+GSTREAMER1_LICENSE = LGPLv2+ LGPLv2.1+
+
+# Checking if unaligned memory access works correctly cannot be done when cross
+# compiling. For the following architectures there is no information available
+# in the configure script.
+ifeq ($(BR2_arc)$(BR2_xtensa)$(BR2_microblaze),y)
+GSTREAMER1_CONF_ENV = as_cv_unaligned_access=no
+endif
+ifeq ($(BR2_aarch64),y)
+GSTREAMER1_CONF_ENV = as_cv_unaligned_access=yes
+endif
+
+GSTREAMER1_CONF_OPTS = \
+       --disable-examples \
+       --disable-tests \
+       --disable-failing-tests \
+       --disable-valgrind \
+       --disable-benchmarks \
+       --disable-check \
+       $(if $(BR2_PACKAGE_GSTREAMER1_TRACE),,--disable-trace) \
+       $(if $(BR2_PACKAGE_GSTREAMER1_PARSE),,--disable-parse) \
+       $(if $(BR2_PACKAGE_GSTREAMER1_GST_DEBUG),,--disable-gst-debug) \
+       $(if $(BR2_PACKAGE_GSTREAMER1_PLUGIN_REGISTRY),,--disable-registry) \
+       $(if $(BR2_PACKAGE_GSTREAMER1_INSTALL_TOOLS),,--disable-tools)
+
+GSTREAMER1_DEPENDENCIES = libglib2 host-pkgconf host-bison host-flex
+
+$(eval $(autotools-package))