The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / gstreamer / gstreamer / gstreamer.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/gstreamer/gstreamer/gstreamer.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/gstreamer/gstreamer/gstreamer.mk
new file mode 100644 (file)
index 0000000..1dbd66f
--- /dev/null
@@ -0,0 +1,32 @@
+################################################################################
+#
+# gstreamer
+#
+################################################################################
+
+GSTREAMER_VERSION = 0.10.36
+GSTREAMER_SOURCE = gstreamer-$(GSTREAMER_VERSION).tar.xz
+GSTREAMER_SITE = http://gstreamer.freedesktop.org/src/gstreamer
+GSTREAMER_INSTALL_STAGING = YES
+
+# Checking if unaligned memory access works correctly cannot be done when cross
+# compiling. For the following architectures there is no information available
+# in the configure script.
+ifeq ($(BR2_arc)$(BR2_xtensa)$(BR2_microblaze),y)
+GSTREAMER_CONF_ENV = as_cv_unaligned_access=no
+endif
+ifeq ($(BR2_aarch64),y)
+GSTREAMER_CONF_ENV = as_cv_unaligned_access=yes
+endif
+
+GSTREAMER_CONF_OPTS = \
+       --disable-examples \
+       --disable-tests \
+       --disable-failing-tests \
+       --disable-loadsave \
+       $(if $(BR2_PACKAGE_GSTREAMER_GST_DEBUG),,--disable-gst-debug) \
+       $(if $(BR2_PACKAGE_GSTREAMER_PLUGIN_REGISTRY),,--disable-registry)
+
+GSTREAMER_DEPENDENCIES = libglib2 host-pkgconf host-bison host-flex
+
+$(eval $(autotools-package))