The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / grantlee / grantlee.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/grantlee/grantlee.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/grantlee/grantlee.mk
new file mode 100644 (file)
index 0000000..a300106
--- /dev/null
@@ -0,0 +1,23 @@
+################################################################################
+#
+# grantlee
+#
+################################################################################
+# qt4 support dropped after 0.5.1, so we use the older version for qt4
+ifeq ($(BR2_PACKAGE_QT),y)
+GRANTLEE_VERSION = 0.5.1
+else ifeq ($(BR2_PACKAGE_QT5),y)
+GRANTLEE_VERSION = 5.0.0
+endif
+GRANTLEE_SITE = http://downloads.grantlee.org
+GRANTLEE_INSTALL_STAGING = YES
+GRANTLEE_LICENSE = LGPLv2.1+
+GRANTLEE_LICENSE_FILES = COPYING.LIB
+
+ifeq ($(BR2_PACKAGE_QT),y)
+GRANTLEE_DEPENDENCIES = qt
+else ifeq ($(BR2_PACKAGE_QT5),y)
+GRANTLEE_DEPENDENCIES += qt5base qt5script
+endif
+
+$(eval $(cmake-package))