The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / gnuplot / gnuplot.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/gnuplot/gnuplot.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/gnuplot/gnuplot.mk
new file mode 100644 (file)
index 0000000..4408ece
--- /dev/null
@@ -0,0 +1,51 @@
+################################################################################
+#
+# gnuplot
+#
+################################################################################
+
+GNUPLOT_VERSION = 4.6.6
+GNUPLOT_SITE = http://downloads.sourceforge.net/project/gnuplot/gnuplot/$(GNUPLOT_VERSION)
+GNUPLOT_LICENSE = gnuplot license (open source)
+GNUPLOT_LICENSE_FILES = Copyright
+
+GNUPLOT_AUTORECONF = YES
+
+GNUPLOT_CONF_OPTS = \
+       --without-x \
+       --disable-raise-console \
+       --disable-mouse \
+       --without-tutorial \
+       --disable-demo \
+       --without-row-help \
+       --disable-history-file \
+       --without-lisp-files \
+       --disable-wxwidgets \
+       --without-lua \
+       --without-latex \
+       --without-cairo
+
+ifeq ($(BR2_PACKAGE_GD)$(BR2_PACKAGE_LIBPNG),yy)
+GNUPLOT_CONF_OPTS += --with-gd
+GNUPLOT_DEPENDENCIES += gd
+GNUPLOT_CONF_ENV += \
+       ac_cv_path_GDLIB_CONFIG=$(STAGING_DIR)/usr/bin/gdlib-config
+else
+GNUPLOT_CONF_OPTS += --without-gd
+endif
+
+ifeq ($(BR2_PACKAGE_READLINE),y)
+GNUPLOT_CONF_OPTS += --with-readline=gnu
+GNUPLOT_DEPENDENCIES += readline
+else
+GNUPLOT_CONF_OPTS += --without-readline
+endif
+
+# Remove Javascript scripts, lua scripts, PostScript files
+define GNUPLOT_REMOVE_UNNEEDED_FILES
+       $(RM) -rf $(TARGET_DIR)/usr/share/gnuplot
+endef
+
+GNUPLOT_POST_INSTALL_TARGET_HOOKS += GNUPLOT_REMOVE_UNNEEDED_FILES
+
+$(eval $(autotools-package))