The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / freescale-imx / libz160 / libz160.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/freescale-imx/libz160/libz160.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/freescale-imx/libz160/libz160.mk
new file mode 100644 (file)
index 0000000..af43b18
--- /dev/null
@@ -0,0 +1,30 @@
+################################################################################
+#
+# libz160
+#
+################################################################################
+
+LIBZ160_VERSION = 11.09.01
+LIBZ160_SOURCE = libz160-bin-$(LIBZ160_VERSION).bin
+LIBZ160_SITE = $(FREESCALE_IMX_SITE)
+LIBZ160_INSTALL_STAGING = YES
+
+# See freescale-imx
+LIBZ160_LICENSE = Freescale Semiconductor Software License Agreement
+LIBZ160_LICENSE_FILES = EULA
+LIBZ160_REDISTRIBUTE = NO
+
+define LIBZ160_EXTRACT_CMDS
+       $(call FREESCALE_IMX_EXTRACT_HELPER,$(DL_DIR)/$(LIBZ160_SOURCE))
+endef
+
+define LIBZ160_INSTALL_STAGING_CMDS
+       $(INSTALL) -D -m 755 $(@D)/usr/lib/libz160.so $(STAGING_DIR)/usr/lib/libz160.so
+       $(INSTALL) -D -m 644 $(@D)/usr/include/z160.h $(STAGING_DIR)/usr/include/z160.h
+endef
+
+define LIBZ160_INSTALL_TARGET_CMDS
+       $(INSTALL) -D -m 755 $(@D)/usr/lib/libz160.so $(TARGET_DIR)/usr/lib/libz160.so
+endef
+
+$(eval $(generic-package))