The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / freescale-imx / imx-vpu / imx-vpu.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/freescale-imx/imx-vpu/imx-vpu.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/freescale-imx/imx-vpu/imx-vpu.mk
new file mode 100644 (file)
index 0000000..ab3634d
--- /dev/null
@@ -0,0 +1,42 @@
+################################################################################
+#
+# imx-vpu
+#
+################################################################################
+
+IMX_VPU_VERSION = $(FREESCALE_IMX_VERSION)
+IMX_VPU_SITE = $(FREESCALE_IMX_SITE)
+IMX_VPU_SOURCE = imx-vpu-$(IMX_VPU_VERSION).bin
+
+IMX_VPU_INSTALL_STAGING = YES
+
+# imx-vpu needs access to imx-specific kernel headers
+IMX_VPU_DEPENDENCIES += linux
+IMX_VPU_MAKE_ENV = \
+       $(TARGET_MAKE_ENV) \
+       $(TARGET_CONFIGURE_OPTS) \
+       CROSS_COMPILE="$(CCACHE) $(TARGET_CROSS)" \
+       PLATFORM=$(BR2_PACKAGE_FREESCALE_IMX_PLATFORM) \
+       INCLUDE="-idirafter $(LINUX_DIR)/include"
+
+IMX_VPU_LICENSE = Freescale Semiconductor Software License Agreement
+IMX_VPU_LICENSE_FILES = EULA vpu/EULA.txt
+IMX_VPU_REDISTRIBUTE = NO
+
+define IMX_VPU_EXTRACT_CMDS
+       $(call FREESCALE_IMX_EXTRACT_HELPER,$(DL_DIR)/$(IMX_VPU_SOURCE))
+endef
+
+define IMX_VPU_BUILD_CMDS
+       $(IMX_VPU_MAKE_ENV) $(MAKE1) -C $(@D)
+endef
+
+define IMX_VPU_INSTALL_STAGING_CMDS
+       $(IMX_VPU_MAKE_ENV) $(MAKE1) -C $(@D) DEST_DIR=$(STAGING_DIR) install
+endef
+
+define IMX_VPU_INSTALL_TARGET_CMDS
+       $(IMX_VPU_MAKE_ENV) $(MAKE1) -C $(@D) DEST_DIR=$(TARGET_DIR) install
+endef
+
+$(eval $(generic-package))