The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / freescale-imx / freescale-imx.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/freescale-imx/freescale-imx.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/freescale-imx/freescale-imx.mk
new file mode 100644 (file)
index 0000000..64f3b6b
--- /dev/null
@@ -0,0 +1,35 @@
+################################################################################
+#
+# freescale-imx
+#
+################################################################################
+
+FREESCALE_IMX_VERSION = 3.10.17-1.0.0
+FREESCALE_IMX_SITE = http://www.freescale.com/lgfiles/NMG/MAD/YOCTO
+
+# Helper for self-extracting binaries distributed by Freescale.
+#
+# The --force option makes sure it doesn't fail if the source
+# directory already exists. The --auto-accept skips the license check,
+# as it is not needed in Buildroot because we have legal-info. Since
+# there's a EULA in the binary file, we extract it in this macro, and
+# it should therefore be added to the LICENSE_FILES variable of
+# packages using this macro. Also, remember to set REDISTRIBUTE to
+# "NO". Indeed, this is a legal minefield: the EULA specifies that the
+# Board Support Package includes software and hardware (sic!) for
+# which a separate license is needed...
+#
+# $(1): full path to the archive file
+#
+define FREESCALE_IMX_EXTRACT_HELPER
+       awk 'BEGIN      { start = 0; } \
+            /^EOEULA/  { start = 0; } \
+                       { if (start) print; } \
+            /<<EOEULA/ { start = 1; }' \
+           $(1) > $(@D)/EULA
+       cd $(@D) && sh $(1) --force --auto-accept
+       find $(@D)/$(basename $(notdir $(1))) -mindepth 1 -maxdepth 1 -exec mv {} $(@D) \;
+       rmdir $(@D)/$(basename $(notdir $(1)))
+endef
+
+include $(sort $(wildcard package/freescale-imx/*/*.mk))