The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / flot / flot.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/flot/flot.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/flot/flot.mk
new file mode 100644 (file)
index 0000000..58e3ff1
--- /dev/null
@@ -0,0 +1,34 @@
+################################################################################
+#
+# flot
+#
+################################################################################
+
+FLOT_VERSION = 0.8.3
+FLOT_SITE = http://www.flotcharts.org/downloads
+FLOT_LICENSE = MIT
+FLOT_LICENSE_FILES = LICENSE.txt
+FLOT_FILES = jquery.flot $(addprefix jquery.flot.,\
+       $(if $(BR2_PACKAGE_FLOT_CANVAS),canvas) \
+       $(if $(BR2_PACKAGE_FLOT_CATEGORIES),categories) \
+       $(if $(BR2_PACKAGE_FLOT_CROSSHAIR),crosshair) \
+       $(if $(BR2_PACKAGE_FLOT_ERRORBARS),errorbars) \
+       $(if $(BR2_PACKAGE_FLOT_FILLBETWEEN),fillbetween) \
+       $(if $(BR2_PACKAGE_FLOT_IMAGE),image) \
+       $(if $(BR2_PACKAGE_FLOT_NAVIGATE),navigate) \
+       $(if $(BR2_PACKAGE_FLOT_PIE),pie) \
+       $(if $(BR2_PACKAGE_FLOT_RESIZE),resize) \
+       $(if $(BR2_PACKAGE_FLOT_SELECTION),selection) \
+       $(if $(BR2_PACKAGE_FLOT_STACK),stack) \
+       $(if $(BR2_PACKAGE_FLOT_SYMBOL),symbol) \
+       $(if $(BR2_PACKAGE_FLOT_THRESHOLD),threshold) \
+       $(if $(BR2_PACKAGE_FLOT_TIME),time) \
+       )
+
+define FLOT_INSTALL_TARGET_CMDS
+       for i in $(FLOT_FILES); do \
+               $(INSTALL) -m 0644 -D $(@D)/$$i.min.js $(TARGET_DIR)/var/www/$$i.js || exit 1; \
+       done
+endef
+
+$(eval $(generic-package))