The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / flite / 0002-fix-alsa-static.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/flite/0002-fix-alsa-static.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/flite/0002-fix-alsa-static.patch
new file mode 100644 (file)
index 0000000..7ed4899
--- /dev/null
@@ -0,0 +1,19 @@
+Use pkg-config to determine alsa link flags. This fixes static linking.
+
+Signed-off-by: Baruch Siach <baruch@tkos.co.il>
+
+diff -Nuar flite-1.4-release.orig/configure.in flite-1.4-release/configure.in
+--- flite-1.4-release.orig/configure.in        2009-08-14 23:46:38.000000000 +0300
++++ flite-1.4-release/configure.in     2014-04-30 18:52:33.253297236 +0300
+@@ -275,7 +275,10 @@
+                 #endif],
+               [AUDIODRIVER="alsa"
+              AUDIODEFS=-DCST_AUDIO_ALSA
+-               AUDIOLIBS=-lasound])
++               AUDIOLIBS=`pkg-config --libs alsa`
++               if test "$shared" = false; then
++                   AUDIOLIBS=`pkg-config --libs --static alsa`
++               fi])
+ AC_CHECK_HEADER(mmsystem.h,
+             [AUDIODRIVER="wince"
+              AUDIODEFS=-DCST_AUDIO_WINCE