The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / flac / flac.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/flac/flac.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/flac/flac.mk
new file mode 100644 (file)
index 0000000..b819064
--- /dev/null
@@ -0,0 +1,33 @@
+################################################################################
+#
+# flac
+#
+################################################################################
+
+FLAC_VERSION = 1.3.1
+FLAC_SITE = http://downloads.xiph.org/releases/flac
+FLAC_SOURCE = flac-$(FLAC_VERSION).tar.xz
+FLAC_INSTALL_STAGING = YES
+FLAC_DEPENDENCIES = $(if $(BR2_PACKAGE_LIBICONV),libiconv)
+FLAC_LICENSE = Xiph BSD-like (libFLAC), GPLv2+ (tools), LGPLv2.1+ (other libraries)
+FLAC_LICENSE_FILES = COPYING.Xiph COPYING.GPL COPYING.LGPL
+FLAC_CONF_OPTS = \
+       --disable-cpplibs \
+       --disable-xmms-plugin \
+       --disable-altivec
+
+ifeq ($(BR2_PACKAGE_LIBOGG),y)
+FLAC_CONF_OPTS += --with-ogg=$(STAGING_DIR)/usr
+FLAC_DEPENDENCIES += libogg
+else
+FLAC_CONF_OPTS += --disable-ogg
+endif
+
+ifeq ($(BR2_X86_CPU_HAS_SSE),y)
+FLAC_DEPENDENCIES += host-nasm
+FLAC_CONF_OPTS += --enable-sse
+else
+FLAC_CONF_OPTS += --disable-sse
+endif
+
+$(eval $(autotools-package))