The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / fis / fis.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/fis/fis.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/fis/fis.mk
new file mode 100644 (file)
index 0000000..876b127
--- /dev/null
@@ -0,0 +1,22 @@
+################################################################################
+#
+# fis
+#
+################################################################################
+
+FIS_SITE = http://svn.chezphil.org/utils/trunk
+FIS_SITE_METHOD = svn
+FIS_VERSION = 2892
+FIS_LICENSE = GPLv2+
+FIS_LICENSE_FILES = fis.c
+
+define FIS_BUILD_CMDS
+       $(TARGET_CC) $(TARGET_CFLAGS) -std=c99 -o $(@D)/fis \
+               $(@D)/fis.c $(@D)/crc.c $(TARGE_LDFLAGS)
+endef
+
+define FIS_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 0755 -D $(@D)/fis $(TARGET_DIR)/sbin/fis
+endef
+
+$(eval $(generic-package))