The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / fio / fio.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/fio/fio.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/fio/fio.mk
new file mode 100644 (file)
index 0000000..f9a690e
--- /dev/null
@@ -0,0 +1,24 @@
+################################################################################
+#
+# fio
+#
+################################################################################
+
+FIO_VERSION = fio-2.1.4
+FIO_SITE = git://git.kernel.dk/fio.git
+FIO_LICENSE = GPLv2 + special obligations
+FIO_LICENSE_FILES = LICENSE
+
+define FIO_CONFIGURE_CMDS
+       (cd $(@D); ./configure --cc="$(TARGET_CC)" --extra-cflags="$(TARGET_CFLAGS)")
+endef
+
+define FIO_BUILD_CMDS
+       $(MAKE) -C $(@D)
+endef
+
+define FIO_INSTALL_TARGET_CMDS
+       $(INSTALL) -D $(@D)/fio $(TARGET_DIR)/usr/bin/fio
+endef
+
+$(eval $(generic-package))