The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / fbset / fbset.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/fbset/fbset.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/fbset/fbset.mk
new file mode 100644 (file)
index 0000000..16581c4
--- /dev/null
@@ -0,0 +1,25 @@
+################################################################################
+#
+# fbset
+#
+################################################################################
+
+FBSET_VERSION = 2.1
+FBSET_SITE = http://users.telenet.be/geertu/Linux/fbdev
+FBSET_DEPENDENCIES = host-bison host-flex
+FBSET_LICENSE = GPLv2
+
+# Make sure full fbset wins over busybox fbset
+ifeq ($(BR2_PACKAGE_BUSYBOX),y)
+FBSET_DEPENDENCIES += busybox
+endif
+
+define FBSET_BUILD_CMDS
+       $(MAKE1) $(TARGET_CONFIGURE_OPTS) -C $(@D)
+endef
+
+define FBSET_INSTALL_TARGET_CMDS
+       $(INSTALL) -D -m 755 $(@D)/fbset $(TARGET_DIR)/usr/sbin/fbset
+endef
+
+$(eval $(generic-package))