The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / faifa / faifa.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/faifa/faifa.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/faifa/faifa.mk
new file mode 100644 (file)
index 0000000..a56a8c0
--- /dev/null
@@ -0,0 +1,41 @@
+################################################################################
+#
+# faifa
+#
+################################################################################
+
+FAIFA_VERSION = v0.1
+FAIFA_SITE = $(call github,ffainelli,faifa,$(FAIFA_VERSION))
+FAIFA_INSTALL_STAGING = YES
+FAIFA_DEPENDENCIES = libpcap host-autoconf
+FAIFA_LICENSE = BSD-3c
+FAIFA_LICENSE_FILES = COPYING
+
+FAIFA_MAKE_OPTS += GIT_REV=$(FAIFA_VERSION)
+
+# This package uses autoconf, but not automake, so we need to call
+# their special autogen.sh script, and have custom target and staging
+# installation commands.
+
+define FAIFA_RUN_AUTOGEN
+       cd $(@D) && PATH=$(BR_PATH) ./autogen.sh
+endef
+FAIFA_PRE_CONFIGURE_HOOKS += FAIFA_RUN_AUTOGEN
+
+define FAIFA_INSTALL_TARGET_CMDS
+       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
+               PREFIX=/usr \
+               STRIP=/bin/true \
+               DESTDIR=$(TARGET_DIR) \
+               install
+endef
+
+define FAIFA_INSTALL_STAGING_CMDS
+       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
+               PREFIX=/usr \
+               STRIP=/bin/true \
+               DESTDIR=$(STAGING_DIR) \
+               install
+endef
+
+$(eval $(autotools-package))