The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / empty / empty.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/empty/empty.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/empty/empty.mk
new file mode 100644 (file)
index 0000000..3339ff6
--- /dev/null
@@ -0,0 +1,21 @@
+################################################################################
+#
+# empty
+#
+################################################################################
+
+EMPTY_VERSION = 0.6.19b
+EMPTY_SOURCE = empty-$(EMPTY_VERSION).tgz
+EMPTY_SITE = http://downloads.sourceforge.net/project/empty/empty/empty-$(EMPTY_VERSION)
+EMPTY_LICENSE = BSD-3c
+EMPTY_LICENSE_FILES = COPYRIGHT
+
+define EMPTY_BUILD_CMDS
+       $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) all
+endef
+
+define EMPTY_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 0755 -D $(@D)/empty $(TARGET_DIR)/usr/bin/empty
+endef
+
+$(eval $(generic-package))