The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / efl / libedbus / libedbus.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/efl/libedbus/libedbus.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/efl/libedbus/libedbus.mk
new file mode 100644 (file)
index 0000000..18f047a
--- /dev/null
@@ -0,0 +1,37 @@
+################################################################################
+#
+# libedbus
+#
+################################################################################
+
+LIBEDBUS_VERSION = $(EFL_VERSION)
+LIBEDBUS_SOURCE = e_dbus-$(LIBEDBUS_VERSION).tar.bz2
+LIBEDBUS_SITE = http://download.enlightenment.org/releases
+LIBEDBUS_LICENSE = BSD-2c
+LIBEDBUS_LICENSE_FILES = COPYING
+
+LIBEDBUS_INSTALL_STAGING = YES
+
+LIBEDBUS_DEPENDENCIES = host-pkgconf dbus libeina libecore
+
+ifeq ($(BR2_PACKAGE_LIBEDBUS_BLUEZ),y)
+LIBEDBUS_CONF_OPTS += --enable-ebluez
+LIBEDBUS_DEPENDENCIES += bluez_utils
+else
+LIBEDBUS_CONF_OPTS += --disable-ebluez
+endif
+
+ifeq ($(BR2_PACKAGE_LIBEDBUS_CONNMAN),y)
+LIBEDBUS_CONF_OPTS += --enable-econnman0_7x
+LIBEDBUS_DEPENDENCIES += connman
+else
+LIBEDBUS_CONF_OPTS += --disable-econnman0_7x
+endif
+
+ifeq ($(BR2_PACKAGE_LIBEDBUS_NOTIFY),y)
+LIBEDBUS_CONF_OPTS += --enable-enotify --disable-edbus-notify-test
+else
+LIBEDBUS_CONF_OPTS += --disable-enotify
+endif
+
+$(eval $(autotools-package))