The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / ed / ed.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/ed/ed.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/ed/ed.mk
new file mode 100644 (file)
index 0000000..f3bcb74
--- /dev/null
@@ -0,0 +1,31 @@
+################################################################################
+#
+# ed
+#
+################################################################################
+
+ED_VERSION = 1.9
+ED_SITE = $(BR2_GNU_MIRROR)/ed
+ED_CONF_OPTS = \
+       CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" \
+       LDFLAGS="$(TARGET_LDFLAGS)"
+ED_LICENSE = GPLv3+
+ED_LICENSE_FILES = COPYING
+
+define ED_CONFIGURE_CMDS
+       (cd $(@D); \
+               ./configure \
+               --prefix=/usr \
+               $(TARGET_CONFIGURE_OPTS) \
+       )
+endef
+
+define ED_BUILD_CMDS
+       $(MAKE) -C $(@D)
+endef
+
+define ED_INSTALL_TARGET_CMDS
+       $(MAKE) -C $(@D) DESTDIR="$(TARGET_DIR)" install
+endef
+
+$(eval $(generic-package))