The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / dtv-scan-tables / dtv-scan-tables.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/dtv-scan-tables/dtv-scan-tables.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/dtv-scan-tables/dtv-scan-tables.mk
new file mode 100644 (file)
index 0000000..4114d23
--- /dev/null
@@ -0,0 +1,27 @@
+################################################################################
+#
+# dtv-scan-tables
+#
+################################################################################
+
+DTV_SCAN_TABLES_VERSION = f2053b34a5ac6f263edc22888b0db4b1fa563fe4
+DTV_SCAN_TABLES_SITE = http://git.linuxtv.org/cgit.cgi/dtv-scan-tables.git
+DTV_SCAN_TABLES_SITE_METHOD = git
+
+# This package only contains the transponders data. This is not a 'work'
+# as per traditional copyright, but just a collection of 'facts', so there's
+# probably no license to apply to these data files.
+# However, the package prominently contains the COPYING and COPYING.LIB
+# license files (respectively for the GPLv2 and the LGPLv2.1), so we use
+# that as the licensing information.
+DTV_SCAN_TABLES_LICENSE = GPLv2 LGPLv2.1
+DTV_SCAN_TABLES_LICENSE_FILES = COPYING COPYING.LGPL
+
+define DTV_SCAN_TABLES_INSTALL_TARGET_CMDS
+       for f in atsc dvb-c dvb-s dvb-t; do \
+               $(INSTALL) -d -m 0755 $(TARGET_DIR)/usr/share/dvb/$$f; \
+               $(INSTALL) $(@D)/$$f/* $(TARGET_DIR)/usr/share/dvb/$$f; \
+       done
+endef
+
+$(eval $(generic-package))