The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / dtc / dtc.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/dtc/dtc.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/dtc/dtc.mk
new file mode 100644 (file)
index 0000000..e094f7b
--- /dev/null
@@ -0,0 +1,47 @@
+################################################################################
+#
+# dtc
+#
+################################################################################
+
+DTC_VERSION = 1.4.1
+DTC_SOURCE = dtc-$(DTC_VERSION).tar.xz
+DTC_SITE = https://www.kernel.org/pub/software/utils/dtc
+DTC_LICENSE = GPLv2+/BSD-2c
+DTC_LICENSE_FILES = README.license GPL
+DTC_INSTALL_STAGING = YES
+DTC_DEPENDENCIES = host-bison host-flex
+
+define DTC_POST_INSTALL_TARGET_RM_DTDIFF
+       rm -f $(TARGET_DIR)/usr/bin/dtdiff
+endef
+
+ifeq ($(BR2_PACKAGE_DTC_PROGRAMS),y)
+
+DTC_LICENSE += (for the library), GPLv2+ (for the executables)
+DTC_INSTALL_GOAL = install
+ifeq ($(BR2_PACKAGE_BASH),)
+DTC_POST_INSTALL_TARGET_HOOKS += DTC_POST_INSTALL_TARGET_RM_DTDIFF
+endif
+
+else # $(BR2_PACKAGE_DTC_PROGRAMS) != y
+
+DTC_INSTALL_GOAL = install-lib
+
+endif # $(BR2_PACKAGE_DTC_PROGRAMS) != y
+
+define DTC_BUILD_CMDS
+       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) PREFIX=/usr
+endef
+
+# For staging, only the library is needed
+define DTC_INSTALL_STAGING_CMDS
+       $(MAKE) -C $(@D) DESTDIR=$(STAGING_DIR) PREFIX=/usr install-lib \
+               install-includes
+endef
+
+define DTC_INSTALL_TARGET_CMDS
+       $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) PREFIX=/usr $(DTC_INSTALL_GOAL)
+endef
+
+$(eval $(generic-package))