The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / dropwatch / dropwatch.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/dropwatch/dropwatch.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/dropwatch/dropwatch.mk
new file mode 100644 (file)
index 0000000..3565927
--- /dev/null
@@ -0,0 +1,34 @@
+################################################################################
+#
+# dropwatch
+#
+################################################################################
+
+DROPWATCH_VERSION = 1.4
+DROPWATCH_SOURCE = dropwatch-$(DROPWATCH_VERSION).tar.xz
+DROPWATCH_SITE = https://git.fedorahosted.org/cgit/dropwatch.git/snapshot
+DROPWATCH_DEPENDENCIES = binutils libnl readline host-pkgconf
+DROPWATCH_LICENSE = GPLv2
+DROPWATCH_LICENSE_FILES = COPYING
+
+# libbfd may be linked to libintl
+# Ugly... but LDFLAGS are hardcoded anyway
+DROPWATCH_LDFLAGS = \
+       $(TARGET_LDFLAGS) -lbfd -lreadline -lnl-3 -lnl-genl-3 \
+               -lpthread -lncurses -lm
+
+ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE),y)
+DROPWATCH_LDFLAGS += -lintl
+endif
+
+define DROPWATCH_BUILD_CMDS
+       $(TARGET_CONFIGURE_OPTS) $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
+               LDFLAGS="$(DROPWATCH_LDFLAGS)" build
+endef
+
+define DROPWATCH_INSTALL_TARGET_CMDS
+       $(INSTALL) -D -m 0755 $(@D)/src/dropwatch \
+               $(TARGET_DIR)/usr/bin/dropwatch
+endef
+
+$(eval $(generic-package))