The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / dropwatch / 0001-build.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/dropwatch/0001-build.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/dropwatch/0001-build.patch
new file mode 100644 (file)
index 0000000..eed43e8
--- /dev/null
@@ -0,0 +1,27 @@
+From 03bab84ca3f102274837e83ee6da4c997a9da018 Mon Sep 17 00:00:00 2001
+From: Tzu-Jung Lee <tjlee@ambarella.com>
+Date: Fri, 12 Jul 2013 20:00:57 +0800
+Subject: [PATCH] build: modify hardcoded gcc to support buildroot
+
+Signed-off-by: Tzu-Jung Lee <tjlee@ambarella.com>
+
+diff --git a/src/Makefile b/src/Makefile
+index 026b6ba..b87ae9f 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -5,10 +5,10 @@ OBJFILES := main.o lookup.o\
+        lookup_bfd.o lookup_kas.o
+ dropwatch: $(OBJFILES) 
+-      gcc -g -o dropwatch $(OBJFILES) $(LDFLAGS) 
++      $(CC) -g -o dropwatch $(OBJFILES) $(LDFLAGS)
+ %.o: %.c
+-      gcc $(CFLAGS) $<
++      $(CC) $(CFLAGS) $<
+ clean:
+       rm -f dropwatch *.o
+-- 
+1.8.3.2
+