The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / dmidecode / 0001-build-system-fixes.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/dmidecode/0001-build-system-fixes.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/dmidecode/0001-build-system-fixes.patch
new file mode 100644 (file)
index 0000000..275f9df
--- /dev/null
@@ -0,0 +1,35 @@
+Minor build system fixes
+
+Usual build system fixes to allow CC/CFLAGS/LDFLAGS to be overriden
+from the command line, and completed by additional flags from the
+Makefile.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/Makefile
+===================================================================
+--- a/Makefile
++++ b/Makefile
+@@ -12,9 +12,10 @@
+ #   (at your option) any later version.
+ #
+-CC      = gcc
+-CFLAGS  = -W -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual \
+-          -Wcast-align -Wwrite-strings -Wmissing-prototypes -Winline -Wundef
++CC      ?= gcc
++override CFLAGS  += \
++      -W -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual \
++        -Wcast-align -Wwrite-strings -Wmissing-prototypes -Winline -Wundef
+ #CFLAGS += -DBIGENDIAN
+ #CFLAGS += -DALIGNMENT_WORKAROUND
+@@ -23,7 +24,7 @@
+ #CFLAGS += -g
+ # Pass linker flags here
+-LDFLAGS =
++override LDFLAGS +=
+ DESTDIR =
+ prefix  = /usr/local