The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / dialog / dialog.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/dialog/dialog.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/dialog/dialog.mk
new file mode 100644 (file)
index 0000000..f207f75
--- /dev/null
@@ -0,0 +1,22 @@
+################################################################################
+#
+# dialog
+#
+################################################################################
+
+DIALOG_VERSION = 1.2-20150125
+DIALOG_SOURCE = dialog-$(DIALOG_VERSION).tgz
+DIALOG_SITE = ftp://invisible-island.net/dialog
+DIALOG_CONF_OPTS = --with-ncurses --with-curses-dir=$(STAGING_DIR)/usr \
+       --disable-rpath-hack
+DIALOG_DEPENDENCIES = host-pkgconf ncurses
+DIALOG_LICENSE = LGPLv2.1
+DIALOG_LICENSE_FILES = COPYING
+
+ifneq ($(BR2_ENABLE_LOCALE),y)
+DIALOG_DEPENDENCIES += libiconv
+endif
+
+DIALOG_CONF_OPTS += NCURSES_CONFIG=$(STAGING_DIR)/usr/bin/$(NCURSES_CONFIG_SCRIPTS)
+
+$(eval $(autotools-package))