The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / dbus-python / dbus-python.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/dbus-python/dbus-python.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/dbus-python/dbus-python.mk
new file mode 100644 (file)
index 0000000..9bda018
--- /dev/null
@@ -0,0 +1,31 @@
+################################################################################
+#
+# dbus-python
+#
+################################################################################
+
+DBUS_PYTHON_VERSION = 1.2.0
+DBUS_PYTHON_SITE = http://dbus.freedesktop.org/releases/dbus-python
+DBUS_PYTHON_INSTALL_STAGING = YES
+DBUS_PYTHON_LICENSE = MIT
+DBUS_PYTHON_LICENSE_FILES = COPYING
+DBUS_PYTHON_DEPENDENCIES = dbus-glib
+DBUS_PYTHON_CONF_OPTS = --disable-html-docs --disable-api-docs
+
+ifeq ($(BR2_PACKAGE_PYTHON),y)
+DBUS_PYTHON_DEPENDENCIES += python host-python
+
+DBUS_PYTHON_CONF_ENV += \
+       PYTHON=$(HOST_DIR)/usr/bin/python2 \
+       PYTHON_INCLUDES="$(shell $(STAGING_DIR)/usr/bin/python2-config --includes)" \
+       PYTHON_LIBS="$(shell $(STAGING_DIR)/usr/bin/python2-config --ldflags)"
+else
+DBUS_PYTHON_DEPENDENCIES += python3 host-python3
+
+DBUS_PYTHON_CONF_ENV += \
+       PYTHON=$(HOST_DIR)/usr/bin/python3 \
+       PYTHON_INCLUDES="$(shell $(STAGING_DIR)/usr/bin/python3-config --includes)" \
+       PYTHON_LIBS="$(shell $(STAGING_DIR)/usr/bin/python3-config --ldflags)"
+endif
+
+$(eval $(autotools-package))