The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / czmq / czmq.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/czmq/czmq.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/czmq/czmq.mk
new file mode 100644 (file)
index 0000000..3d82095
--- /dev/null
@@ -0,0 +1,27 @@
+################################################################################
+#
+# czmq
+#
+################################################################################
+
+CZMQ_VERSION = v3.0.0
+CZMQ_SITE = $(call github,zeromq,czmq,$(CZMQ_VERSION))
+
+# Autoreconf required as we use the git tree
+CZMQ_AUTORECONF = YES
+CZMQ_INSTALL_STAGING = YES
+CZMQ_DEPENDENCIES = zeromq host-pkgconf
+CZMQ_LICENSE = MPLv2.0
+CZMQ_LICENSE_FILES = LICENSE
+
+# asciidoc is a python script that imports unicodedata, which is not in
+# host-python, so disable asciidoc entirely.
+CZMQ_CONF_ENV = ac_cv_prog_czmq_have_asciidoc=no
+
+define CZMQ_CREATE_CONFIG_DIR
+       mkdir -p $(@D)/config
+endef
+
+CZMQ_POST_PATCH_HOOKS += CZMQ_CREATE_CONFIG_DIR
+
+$(eval $(autotools-package))