The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / cwiid / cwiid.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/cwiid/cwiid.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/cwiid/cwiid.mk
new file mode 100644 (file)
index 0000000..0cfc774
--- /dev/null
@@ -0,0 +1,30 @@
+################################################################################
+#
+# cwiid
+#
+################################################################################
+
+CWIID_VERSION = 0.6.00
+CWIID_SOURCE = cwiid-$(CWIID_VERSION).tgz
+CWIID_SITE = http://abstrakraft.org/cwiid/downloads
+CWIID_LICENSE = GPLv2+
+CWIID_LICENSE_FILES = COPYING
+
+CWIID_AUTORECONF = YES
+CWIID_INSTALL_STAGING = YES
+
+CWIID_DEPENDENCIES = host-pkgconf host-bison host-flex bluez_utils
+
+# Disable python support. This disables the 2 following things:
+#   - wminput Python plugin support
+#   - cwiid Python module
+CWIID_CONF_OPTS = --without-python --disable-ldconfig
+
+ifeq ($(BR2_PACKAGE_CWIID_WMGUI),y)
+CWIID_DEPENDENCIES += libgtk2 libglib2
+CWIID_CONF_OPTS += --enable-wmgui
+else
+CWIID_CONF_OPTS += --disable-wmgui
+endif
+
+$(eval $(autotools-package))