The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / cryptodev-linux / 0002-fix-ccache-compile.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/cryptodev-linux/0002-fix-ccache-compile.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/cryptodev-linux/0002-fix-ccache-compile.patch
new file mode 100644 (file)
index 0000000..058fb43
--- /dev/null
@@ -0,0 +1,20 @@
+Fix compilation with ccache enabled
+
+When ccache is enabled the CROSS_COMPILE variable contains a space, so
+it must be properly quoted.
+
+Signed-off-by: Doug Kehn <rdkehn@yahoo.com>
+
+Index: cryptodev-linux-1.7/Makefile
+===================================================================
+--- cryptodev-linux-1.7.orig/Makefile
++++ cryptodev-linux-1.7/Makefile
+@@ -18,7 +18,7 @@ ifneq (${ARCH},)
+ KERNEL_MAKE_OPTS += ARCH=${ARCH}
+ endif
+ ifneq (${CROSS_COMPILE},)
+-KERNEL_MAKE_OPTS += CROSS_COMPILE=${CROSS_COMPILE}
++KERNEL_MAKE_OPTS += CROSS_COMPILE="${CROSS_COMPILE}"
+ endif
+ build: version.h