The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / cgic / cgic.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/cgic/cgic.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/cgic/cgic.mk
new file mode 100644 (file)
index 0000000..f07c62e
--- /dev/null
@@ -0,0 +1,25 @@
+################################################################################
+#
+# cgic
+#
+################################################################################
+
+CGIC_VERSION = 2.06
+CGIC_SOURCE = cgic206.tar.gz
+CGIC_SITE = http://boutell.com/cgic
+CGIC_LICENSE = Custom
+CGIC_LICENSE_FILES = license.txt
+
+# Installs only a static library and a header file
+CGIC_INSTALL_STAGING = YES
+CGIC_INSTALL_TARGET = NO
+
+define CGIC_BUILD_CMDS
+       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) libcgic.a
+endef
+
+define CGIC_INSTALL_STAGING_CMDS
+       $(TARGET_CONFIGURE_OPTS) $(MAKE) PREFIX=$(STAGING_DIR) -C $(@D) install
+endef
+
+$(eval $(generic-package))