The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / celt051 / celt051.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/celt051/celt051.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/celt051/celt051.mk
new file mode 100644 (file)
index 0000000..9e25781
--- /dev/null
@@ -0,0 +1,30 @@
+################################################################################
+#
+# celt
+#
+################################################################################
+
+# Although version newer than 0.5.1.3 exists, we're
+# stuck with 0.5.1.3 for use by Spice (coming later)
+CELT051_VERSION = 0.5.1.3
+CELT051_SOURCE = celt-$(CELT051_VERSION).tar.gz
+CELT051_SITE = http://downloads.xiph.org/releases/celt
+CELT051_LICENSE = BSD-2c
+CELT051_LICENSE_FILES = COPYING
+CELT051_INSTALL_STAGING = YES
+CELT051_DEPENDENCIES = libogg
+
+# Need to specify --with-ogg, otherwise /usr/lib may be searched for
+# if target is the same kind as host (ie. same arch, same bitness,
+# same endianness, so that /usr/lib contains libraries linkable by
+# our cross-compiler)
+CELT051_CONF_OPTS =                       \
+       --enable-fixed-point              \
+       --disable-fixed-point-debug       \
+       --disable-experimental-postfilter \
+       --disable-static-modes            \
+       --disable-assertions              \
+       --disable-oggtest                 \
+       --with-ogg=$(STAGING_DIR)/usr     \
+
+$(eval $(autotools-package))