The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / cegui06 / cegui06.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/cegui06/cegui06.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/cegui06/cegui06.mk
new file mode 100644 (file)
index 0000000..43d3b09
--- /dev/null
@@ -0,0 +1,36 @@
+################################################################################
+#
+# cegui06
+#
+################################################################################
+
+# Do not update the version, we need exactly that one for Spice.
+CEGUI06_VERSION_MAJOR = 0.6.2
+CEGUI06_VERSION = $(CEGUI06_VERSION_MAJOR)b
+CEGUI06_SOURCE = CEGUI-$(CEGUI06_VERSION).tar.gz
+CEGUI06_SITE = http://downloads.sourceforge.net/project/crayzedsgui/CEGUI%20Mk-2/$(CEGUI06_VERSION_MAJOR)
+CEGUI06_LICENSE = MIT
+CEGUI06_LICENSE_FILES = COPYING
+CEGUI06_INSTALL_STAGING = YES
+
+CEGUI06_DEPENDENCIES =              \
+       expat                       \
+       freetype                    \
+       pcre                        \
+
+CEGUI06_CONF_OPTS =                 \
+       --enable-expat              \
+       --disable-external-tinyxml  \
+       --disable-xerces-c          \
+       --disable-libxml            \
+       --disable-tinyxml           \
+       --disable-opengl-renderer   \
+       --disable-external-glew     \
+       --disable-irrlicht-renderer \
+       --disable-directfb-renderer \
+       --disable-samples           \
+       --disable-lua-module        \
+       --disable-toluacegui        \
+       --disable-external-toluapp  \
+
+$(eval $(autotools-package))