The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / cache-calibrator / cache-calibrator.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/cache-calibrator/cache-calibrator.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/cache-calibrator/cache-calibrator.mk
new file mode 100644 (file)
index 0000000..d062065
--- /dev/null
@@ -0,0 +1,24 @@
+################################################################################
+#
+# cache-calibrator
+#
+################################################################################
+
+CACHE_CALIBRATOR_SOURCE = calibrator.c
+CACHE_CALIBRATOR_SITE = http://homepages.cwi.nl/~manegold/Calibrator/src
+CACHE_CALIBRATOR_LICENSE = Cache calibrator license
+CACHE_CALIBRATOR_LICENSE_FILES = calibrator.c
+
+define CACHE_CALIBRATOR_EXTRACT_CMDS
+       cp $(DL_DIR)/$(CACHE_CALIBRATOR_SOURCE) $(@D)
+endef
+
+define CACHE_CALIBRATOR_BUILD_CMDS
+       $(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS) $(@D)/calibrator.c -o $(@D)/cache_calibrator -lm
+endef
+
+define CACHE_CALIBRATOR_INSTALL_TARGET_CMDS
+       $(INSTALL) -D -m 0755 $(@D)/cache_calibrator $(TARGET_DIR)/usr/bin/cache_calibrator
+endef
+
+$(eval $(generic-package))